Gruntwork-install returns an error

#1

Hi,

When I run both those commands :

gruntwork-install --binary-name 'gruntkms' --repo 'https://github.com/gruntwork-io/gruntkms' --tag 'v0.0.5'
gruntwork-install --module-name 'aws-auth' --repo 'https://github.com/gruntwork-io/module-security' --tag "v0.5.1"

…I get the following error:

Received HTTP Response 404 while fetching releases for GitHub URL https://github.com/gruntwork-io/module-security. Full HTTP response: {“message”:“Not Found”,“documentation_url”:“https://developer.github.com/v3/repos/#list-tags”}

I DO have been added to the Gruntwork GitHub organization.

I DO have set a GITHUB_OAUTH_TOKEN environment variable on my machine.

I double checked and both tags are OK. I tried with the last tag of aws-auth, to no avail.

What am I doing wrong?

#2

Do both commands fail, or just the module-security one?

#3

I ran the exact command you posted:

gruntwork-install --module-name 'aws-auth' --repo 'https://github.com/gruntwork-io/module-security' --tag "v0.5.1"

And here’s the output I received:

$ gruntwork-install --module-name 'aws-auth' --repo 'https://github.com/gruntwork-io/module-security' --tag "v0.5.1"
2018-03-23 06:16:00 [INFO] [gruntwork-install] Installing from aws-auth...af80881
2018-03-23 06:16:00 [INFO] [gruntwork-install] Downloading module aws-auth from https://github.com/gruntwork-io/module-security
Downloading tag "v0.5.1" of https://github.com/gruntwork-io/module-security ...
Extracting files from <repo>/modules/aws-auth to /tmp/gruntwork-script-modules/aws-auth ...
Download and file extraction complete.
2018-03-23 06:16:01 [INFO] [gruntwork-install] Executing /tmp/gruntwork-script-modules/aws-auth/install.sh
2018-03-23 06:16:01 [INFO] [gruntwork-install] Success!

If your GITHUB_OAUTH_TOKEN were not set, you’d get a different error, so perhaps it’s set to the wrong value? Are you sure that GitHub Token is still valid and gives you access to the desired repo?

#4

OK I’ve found the problem. The personal access token was fine by itself, but I had to edit it on GitHub and check the “repo: Full control of private repositories” authorization. I thought it was to give YOU access to MY private repositories.

Now both commands work flawlessly.

Your insight helped a lot to pinpoint the problem. Thank you.

1 Like