SSH Key Agent on windows

I’m trying to get started with terragrunt but I’m using windows and unable to get terragrunt to use my key that is in KeePass Agent. I’ve tried setting GIT_SSH to plink but that doesn’t work. I’d rather not have my key outside of KeePass.

Keep in mind that Terragrunt is just a thin wrapper on top of Terraform and therefore has no natively support for SSH settings. At the end of the day, Terragrunt is just executing a bunch of Terraform commands under the hood. So as a starting point, I’d encourage you to examine Terragrunt logs and re-run the exact Terraform command that triggers your error.

Once you’ve done that, you can engage the Terraform community on this particular issue, and indeed it looks like this is a known issue.